RBS Change 3.5.8 et 3.6.3 disponibles au téléchargement

Écrit par RBS Change - 26/11/2012 17:20
Les versions correctives pour RBS Change 3.5 et 3.6 sont maintenant disponibles.
Il s'agit de mises à jour mineures.

Version 3.5.8 :
Version 3.6.3 :
Vous trouverez deux installeurs web pour la version majeure courante (3.6.3) contenant :
- Les modules open source minimum : RBS Change Core
- Tous les modules open source : RBS Change complet - Open Source


Pour effectuer la mise à jour, vous disposez de 3 solutions :

La première, recommandée, en passant par la ligne de commande ou la console web :
- Exécuter la commande updater.migrate download : téléchargement des nouveaux packages et vérification du projet
- Exécuter la commande updater.migrate apply : Mise à jour du projet

La seconde en faisant une migration manuelle :
- Télécharger la librairie de migration :
Version 3.5.8 : http://update.rbschange.fr/libs/migration/migration-3.5.8.zip
Version 3.6.3 : http://update.rbschange.fr/libs/migration/migration-3.6.3.zip
- Décompresser dans le dossier migration à la racine du site
- En vous plaçant à la racine du projet exécuter : php migration/migrate.php

La dernière, déconseillée suite à la découverte d'un comportement aléatoire sur certains serveurs Apache, en utilisant l'interface backoffice du module Mise à jour.

Après le passage en version 3.6.3, un patch du module RSS reste applicable. Ce patch sert à rendre disponible l'ancien bloc de détail des flux RSS. Il n'est pas conseillé de l'appliquer.

Si vous ne l'appliquez pas, vous pouvez initialiser la liste des patchs en exécutant la commande : init-patch-db

Rappel : avant toutes mises à jour, il est impératif de faire une sauvegarde de votre système.

En cas de problèmes ou de questions, merci d'utiliser les Forums.

L'équipe RBS Change

2 commentaires

  • 1. Écrit par rbs@ecocea.com - 04/01/2013 09:52

    Bonjour,

    Il est un point qui n'est pas évoqué pour les migrations c'est quand on a plusieurs versions de retard : la migration est-elle incrémentale et exclusivement 3.6.2->3.6.3 et alors comment trouver les patchs précédents (3.6.1->3.6.2 par exemple) ?
    Ou comprend-elle touss les patchs depuis la version N (et quelle est alors la version de N)?
  • 2. Écrit par Loïc Couturier - 04/01/2013 10:01

    Bonjour,

    Lorsque vous avez plusieurs versions de retard, le mieux est de procéder à chaque migration indépendamment.

    Nous fournissons des libs de migration pour passer d'une version n à n+1.

    Il n'est pas impossible de grouper les migrations mais à ce moment se sera à vous de faire le script de migration et à vous de vous assurer que celui ci fonctionne.

    La commande updater.migrate ne vous permettra d'exécuter que la migration vers la version suivante.

Laissez un commentaire

Saisie du commentaire

 
1366 membres
Aucun membre connecté