Détail du message 62558.11

Message numéro 11 dans le sujet Comment insérer un media dans la mediathèque à partir d'un formulaire FO.

  • 62558.11 en réponse à 62558.10 écrit par Mathias

    11/09/2012 18:10


    Mathias
    Rang : Expert
    forcément je test un peu vite et je me rends compte des erreurs BCP plus tard :)

    en l'occurence, je n'arrive pas à afficher les médias "formattés" qui correspondent aux médias uploadés dans l'histoire en FO.

    je m'explique.
    une fois qu'au sein de mon document spé "histoire", j'ai bien enregistré le media dans l'endroit spécifique que j'ai choisi :
    $fromFolder = DocumentHelper::getDocumentInstance(ModuleService::getInstance()->getRootFolderId('media'), 'modules_generic/rootfolder');
    $relativePath = "Histoires (uploadé par utilisateurs)";
    $parentNode = generic_FolderService::getInstance()->mkdir($fromFolder, $relativePath);
    $parentNodeId = $parentNode->getId(); 
    $media->save($parentNodeId);


    j'ai une erreur 404 sur les médias formattés associés à ces média en FO, alors que le media original est disponible...

    a savoir que mon template ressemble à ça :
    <div class="jcarousel-histoire" tal:define="medias histoire/getAdditionnalVisualArray" tal:condition="medias">
    	<ul id="histoireSlideshow">
    		<li tal:repeat="media medias">
    			<a change:link="document media;class-add histoireSlideLaunch">
    				<img change:media="document media; max-height 90; class 'visualCarouselPreview'" />
    			</a>
    		</li>
    	</ul>
    </div>


    auriez vous une idée de l'origine du problème ?

    Édité par Mathias 11/09/2012 18:14


    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
 
1378 membres
Aucun membre connecté