Détail du message 47099.1

Message numéro 1 dans le sujet Erreur lors de la confirmation d'un compte.

  • 47099.1

    23/11/2011 12:00


    guiom
    Rang : Expert
    Bonjour,

    J'obtiens une erreur 404 lors qu'un utilisateur confirme son adresse mail. Le compte est validé, mais il semble qu'il y a une erreur lors de la redirection vers le tag contextual_website_website_modules_users_edit-profil.
    J'ai bien une page valide sur ce tag.
    voici l'erreur
    2011-11-23 11:05:27     [INFO]  website_UrlRewritingService::getActionToforward(/confirm-email/<code>, <domaine>)
    2011-11-23 11:05:27     [INFO]  website_UrlRewritingService::initCurrrentWebsite, 589, fr
    2011-11-23 11:05:27     [INFO]  Rewrite Action Rule users/ConfirmEmail
    2011-11-23 11:05:27     [INFO]  No translation for m.generic.browsers, gecko_4, fr_FR
    2011-11-23 11:05:27     [INFO]  useractionlogger_ModuleService::addUserDocumentEntry(login.frontend, users) => 2375
    2011-11-23 11:05:27     [INFO]  website_UrlRewritingService::getActionToforward(/website/Mes-informations,661.html,  <domaine>)
    2011-11-23 11:05:27     [INFO]  website_UrlRewritingService::initCurrrentWebsite, 589, fr
    2011-11-23 11:05:27     [INFO]  Generic Document Rule website/ViewDetail cmpref: 661
    2011-11-23 11:05:27     [INFO]  website_UrlRewritingService::getActionToforward(/website/website,  <domaine>)
    2011-11-23 11:05:27     [INFO]  website_UrlRewritingService::initCurrrentWebsite, 589, fr
    2011-11-23 11:05:27     [WARN]  website_UrlRewritingService::getCompatibleActionToForward !!! /website/website, <domaine> !!!
    2011-11-23 11:05:27     [FATAL] Compatibility RewriteUrl: /website/website
    2

    L'erreur 404 est déclenché par la page <domaine>/website/website.

    Je pense que le problème vient du changement du nom de domaine du site principal (changé dans la configuration et sur l'interface suivit d'un compile-config).
    Une autre chose étrange, lors de la compilation de la configuration, AG_DEVELOPMENT_MODE reste à true alors que j'ai indiqué false dans le profil et dans change.properties.

    Merci de m'indiquer comment corriger ces points.

    Édité par guiom 23/11/2011 12:10

 
1377 membres
Aucun membre connecté