Détail du message 49037.1

Message numéro 1 dans le sujet [Import-data] Erreurs "deprecated" stoppent d'exécution.

  • 49037.1

    02/01/2012 14:12


    David Guillot
    Rang : Expert
    Bonjour,

    Lors de notre import de données, certains services déclenchent des envois de notifications. Malheureusement les classes PEAR contiennent du code déprécié (pour notre version de PHP, la 5.3), et les erreurs sont toutes traitées de la même manière par la classe import_ScriptReader, y compris les E_DEPRECATED.

    Du coup, comme solution provisoire, j'ai ajouté E_DEPRECATED à la liste des types d'erreurs ignorées par la gestion des erreurs. Suis-je dans le vrai (auquel cas il faut créer un ticket) ou y a-t-il une manière plus propre de gérer ce problème ?

    Merci d'avance
 
1377 membres
Aucun membre connecté