Développer avec RBS Change : Problème Filtre

  • 82395.1

    15/01/2014 09:42


    mammous
    Rang : Membre
    Bonjour,
    J'ai un problème au niveau des filtres dans mon site, si j'ai par exp un produit qui existe en taille S et que cette taille n'existe plus sur ce produit là, il reste toujours dans les résultats de l'application du Filtre S par exp.
    Je sais pas d'ou ce problème peut provenir?
    une idée SVP??

    Cordialement à vous

    Édité par mammous 15/01/2014 09:42


    Analyste - Développeur Web

    Equipe Ecommerce - Groupe Zannier

    RBS Ecommerce Core - v 3.5.2
  • 82395.2 en réponse à 82395.1 écrit par mammous

    17/01/2014 15:54


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    D'après les symptomes, voici ce à quoi je pense dans un premier temps :
    • Si vous avez deux produits de taille S et que les axes de déclinaison choisis ne permettent pas d'identifier de manière unique une déclinaison, le problème peut simplement venir de là ; le système pourrait éventuellement les compiler en un seul
    • Avez-vous des erreurs dans les logs lorsque le stock passe à 0?
      Si tel est le cas, cela pourrait fournir un début d'explication.
    • Avez-vous regardé en base du côté des stocks produits et produits compilés?
      Si le produit compilé n'est pas à jour cela signifie que vous avez un problème dans la chaine de mise à jour des documents. Relancez une compilation des produits pour voir si cela règle le problème ; si c'est le cas, forcez une recompilation de votre produit, sinon, on peut supposer que vous avez un problème soit à la compilation du produit, soit que ce dernier n'est pas marqué comme étant à recompiler.
    • Avez vous fait le test en indiquant une quantité de 0 à partir de la fiche produit en backoffice et après avoir vérifié via l'onglet synthèse que la fiche produit était à jour en frontoffice?
      Si le problème disparait à ce moment, cela laisse à penser que vous avez un problème dans votre code spécifique et notament sur la décrémentation des stocks.
    • Avez vous fait un clear-all, suivi d'un reset de votre index pour voir si le problème persiste?
      Si cela corrige le problème, on peut supposer qu'il y a du code spécifique qui gêne soit la bonne gestion du cache et de son invalidation, soit qui gêne à la réindexation du produit.


    Voilà les pistes qu'il vous faut explorer.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1384 membres
Aucun membre connecté