Développer avec RBS Change : "Surcharge" de fichiers css qui ne fonctionne pas

  • 34055.1

    28/04/2011 18:51


    shnaps
    Rang : Membre
    Bonjour,

    J'aimerai avoir vos lumières sur un point. Je souhaite modifier une feuille de style dans mon thème.
    J'utilise le thème Webfactory. Les CSS associées à ce thème se trouvent donc dans /www/themes/webfactory/style.
    Le fichier CSS que j'ai modifié est le tplBase.css

    Comme il faut utiliser la méthode de "surcharge" décrite sur le site, je créé donc dans l'arborescence suivante :
    /www/override/themes/webfactory/style/ et y place mon fichier en question.
    J'exécute le "clear-webapp-cache" et je perd toutes mes CSS :/

    J'ai remarqué que dans le fichier tplOne.css, il y a des liens vers mon tplBase.css
    J'ai donc essayé de mettre tplOne.css dans le dossier override, en changeant aussi les chemins
    ( @import url(/themes/webfactory/style/tplBase.css) => @import url(override/themes/webfactory/style/tplBase.css )

    En gros j'ai un peu tout essayé sauf la bonne méthode :)

    J'espère être assez clair, sinon n'hésitez pas à me demander plus d'infos !

    Merci beaucoup !!
  • 34055.2 en réponse à 34055.1 écrit par shnaps

    29/04/2011 10:02


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    En principe la surcharge fonctionne sans problème, en revanche il est possible qu'il y ait une erreur de syntaxe dans votre CSS ce qui cause le problème. Pouvez vous vérifier dans la feuille générée que le contenu soit bon et ne contienne pas une fatale erreur.

    Dans un premier temps vérifiez notamment que toutes les lignes se terminent par un point virgule. Si vous ne voyez pas de raison à ce que ca ne marche pas, je vous invite à transmettre ici le contenu de votre fichier CSS.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 34055.3 en réponse à 34055.2 écrit par Jean-Michel

    02/05/2011 10:54


    shnaps
    Rang : Membre
    Bonjour,

    Et merci, tu avais totalement raison, c'est dans mes CSS qu'il y avait un problème, le système de surcharge fonctionne très bien.
    Merci encore et désolé pour le dérangement :)

    Ciao !
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1359 membres
Aucun membre connecté