Développer avec RBS Change : [Résolu] désactiver recaptcha, fait que l'on ne peut plus accéder au module préférences

  • 59725.1

    05/06/2012 18:03


    Mathias
    Rang : Expert
    Finalement nous avons décidé de ne plus utiliser recaptcha, pour cela je l'ai enlevé de mon change.xml et j'ai supprimé le lien symbolique de mon dossier "modules".

    mais maintenant, quand je vais dans "outils->préférences" j'ai une erreur qui me dit :
    Unknown document model recaptcha_persistentdocument_preferencesmodel.


    du coup, impossible d'accéder aux préférences...

    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 59725.2 en réponse à 59725.1 écrit par Mathias

    06/06/2012 11:40


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Il vaut mieux "désactiver" en retirant les droits sur le module, plutôt que de désinstaller le module de cette manière. Il y a un peu plus d'opérations que cela à faire pour retirer/désactiver un module.

    J'ai commencé un petit howto sur la désinstallation de module, mais pas encore eu le temps de le finir ; ce que je vais essayer de faire prochainement.

    Si le contenu de la base de données n'est pas important, il est toujours envisageable de retirer effectivement le module du fichier change.xml et de supprimer les liens et son code du dossier repository, à la suite de quoi il suffit de lancer un reset-database

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 59725.3 en réponse à 59725.2 écrit par Jean-Michel

    06/06/2012 11:53


    Mathias
    Rang : Expert
    Alors quelle solultion ai-je devant moi, sachant que je l'ai "enlevé sauvagement" car il me bloquait la migration en 3.6 ?

    voici le log du fichier log/updater/updater.log :

    2012-06-01 17:19:07 - ERROR - modules/recaptcha 3.5.0 not found in 3.6.0 Release
    2012-06-01 17:19:07 - ERROR - Unable to download all dependencies.


    je n'ai pas de soucis à le garder en BO mais encore faudrait-il que je puisse :p

    Édité par Mathias 06/06/2012 11:54


    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 59725.4 en réponse à 59725.3 écrit par Mathias

    06/06/2012 12:53


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Comme ça à froid je dirai de retirer le module du fichier change.xml et le remettre (relinker) dans le dossier modules, un peu à la façon d'un module spé pour un projet.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 59725.5 en réponse à 59725.4 écrit par Jean-Michel

    06/06/2012 13:50


    Mathias
    Rang : Expert
    à froid ça marche :)

    par contre pour désactiver les droits sur le module... je ne vois pas bien comment le faire ?

    merci

    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 59725.6 en réponse à 59725.5 écrit par Mathias

    21/06/2012 16:19


    Mathias
    Rang : Expert
    C'est bon j'ai trouvé !
    dans le module utilisateurs, il y a cette petite icône en forme de bouclier avec un petit plus vert (uniquement pour les utilisateurs change) qui permet de définir les droits pour tous les modules en un seul endroit.

    nice :)

    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1377 membres
Aucun membre connecté