Installation RBS Change : [Résolu] Probleme de creation de lien symbolique

  • 65450.1

    27/08/2012 20:52


    de_adneeli
    Rang : Nouveau Membre
    Bonjour ,Je souhaite installer e commerce 3.6.1 et lors de la première étape l'hébergement est incompatible en sachant que pour le moment j'utilise easyphp 5.4.6.Voici le message d'erreur " Warning: symlink(): Cannot create symlink, error code(1314) in C:\Program Files (x86)\EasyPHP-12.1\www\install\lib\assert.php on line 80".
    Comment puis je faire pour pouvoir utiliser e commerce?
  • 65450.2 en réponse à 65450.1 écrit par de_adneeli

    28/08/2012 18:01


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Pour pouvoir installer RBS Change sur Windows cela n'est possible qu'à partir de Windows 7 avec un easyPHP exécuté en tant qu'Administrateur pour qu'il puisse créer les liens symboliques.
    Par ailleurs, Change ne sera compatible avec PHP 5.4 qu'à partir de la version 3.6.2. Donc pour le moment je vous recommande d'utiliser une version 5.3 de PHP.

    Édité par Jean-Michel 28/08/2012 18:05


    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 65450.3 en réponse à 65450.2 écrit par Jean-Michel

    30/08/2012 22:20


    de_adneeli
    Rang : Nouveau Membre
    Merci pour cette réponse.Donc mon probleme viens essentiellement de mon Systeme d'exploitation windows vista. Comment je peut faire pour utiliser e commerce avec vista en ayant pas d'herbergeur pour le moment?
    cordialement
  • 65450.4 en réponse à 65450.3 écrit par de_adneeli

    31/08/2012 11:55


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Après vérification, j'avoue avoir une mauvais mémoire :) les symlinks sont supportés à partir de Windows Vista et PHP 5.3. Donc en principe il suffit d'exécuter easyPHP en tant qu'Administrateur et ça devrait tourner tout seul.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 65450.5 en réponse à 65450.4 écrit par Jean-Michel

    07/09/2012 22:21


    de_adneeli
    Rang : Nouveau Membre
    Bonjour
    J'ai réussi a installer ecommerce en installant une version précédent d'easyphp et en ajoutant quel que module d'easyphp.

    Maintenant j'ai un autre problème, l'installation c'est déroulée correctement mais quand je veut administrer mon site on me demande un nom d'utilisateur et un mot de passe que je ne connais pas et je ne sait pas ou je peut le trouver.Si je tape un identifiant et mot de passe ce message apparait :Ce site ne peut être administrer depuis cette interface.
    et j'ai ce message en haut de ma page
    Strict Standards: Declaration of HttpController::redirect() should be compatible with WebController::redirect($url, $delay = 0) in C:\Program Files (x86)\EasyPHP-12.1\www\repository\framework\framework-3.6.1\libs\mvc\Controller.class.php on line 546

    Pouvez vous m'aider a résoudre ce problème?
    cordialement
  • 65450.6 en réponse à 65450.5 écrit par de_adneeli

    13/09/2012 10:26


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Vous pouvez vous positionner dans le dossier où se trouve le framework et taper la commande suivante :
    php framework/bin/change.php reset-root-user
    


    Ceci aura pour effet de réinitialiser le mot de passe du super administrateur, il vous suffit donc ensuite d'accéder à l'administration. La popup qui s'ouvrira vous demandera alors le nouveau mot de passe pour le super utilisateur.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 65450.7 en réponse à 65450.5 écrit par de_adneeli

    15/09/2012 11:36


    noelaurent
    Rang : Membre
    bonjour,

    Je rencontre le même problème que vous. Pouvez vous m'indiquer précisément quelle version d'easy PHP et quels modules vous avez installé ?

    Merci de votre réponse.

    Cordialement

    NL
  • 65450.8 en réponse à 65450.7 écrit par noelaurent

    15/09/2012 14:22


    gribouille
    Rang : Membre
    Bonjour,

    Après avoir regardé la page de téléchargement d'EasyPHP, je vous conseille la version "EasyPHP 12.0 with PHP 5.3.14", vu que RBS Change demande la version PHP 5.3.

    De même si vous utilisez Windows, les liens symboliques ne sont possibles qu'à partir de PHP 5.3 et à partir de Vista au minimum, cf section historique de la fonction PHP symlink.

    La version de RBS Change (ecommerce ou CMS core) n'a aucune importance, du moment que les prérequis sont remplis.
  • 65450.9 en réponse à 65450.8 écrit par gribouille

    17/09/2012 20:12


    noelaurent
    Rang : Membre
    Bonjour,

    Merci pour votre réponse rapide.
    J'ai actuellement Vista, EasyPhp 12.1 et php 5.3.15.

    Tout devrait donc marcher. A moins que vous ne me conseillez formellement d'utiliser une version antérieure d'easy PhP ?

    Merci encore une fois de votre retour,

    NL
  • 65450.10 en réponse à 65450.9 écrit par noelaurent

    18/09/2012 13:51


    noelaurent
    Rang : Membre
    Bonjour !

    Effectivement ca fonctionne avec EasyPhp12.0 et la version de php que tu m'a indiqué. Juste un petit soucis d'activation du xls et c'est parti !

    Merci encore pour ton soutien.

    Noé

    Édité par Jean-Michel 21/09/2012 11:33

 
Merci de prendre connaissance et de respecter les règles des forums.
 
1377 membres
Aucun membre connecté