Installation RBS Change : Version PHP et FireFox

  • 86241.1

    14/06/2015 18:50


    jclaude
    Rang : Membre
    Bonjour,

    Je déterre un vieux sujet: la compatibilité PHP avec RBS Change.
    Savez-vous ce qu'il en est de sa compatibilité en version 5.5 ?

    Autre chose: les dernières version de FireFox ne semblent pas fonctionner avec l'interface BO. Jusqu'à quelle version avez-vous réussi à le faire fonctionner ? Car je ne souhaite pas rester en version 14.

    Cordialement,
    Jean-Claude
  • 86241.2 en réponse à 86241.1 écrit par jclaude

    16/06/2015 07:53


    Georges Njock-Bôt
    Rang : Membre
    Bonjour jclaude,

    j'ignore ce qu'il en est globalement/officiellement concernant la compatibilité 5.5
    Par contre, je sais que certains problèmes d'affichage backoffice étaient liés à un bug interne à PHP.
    Ce point est fixé (entre autre) par la pull request suivante https://github.com/RBSChange/modules.uixul/pull/1

    Puisqu'il n'y a pas eu de release après cette pull request, il vous faudra sans doute l'intégrer vous même
    à votre module uixul standard local.

    Cordialement.

    "La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information"

    Albert Einstein
  • 86241.3 en réponse à 86241.2 écrit par Georges Njock-Bôt

    25/07/2015 04:26


    jclaude
    Rang : Membre
    Bonjour,

    Merci pour votre réponse.

    J'ai en effet appliqué les correctifs et il y a du mieux à l'exception du bug remonté par fx à la fin de ce thread:
    http://www.rbschange.....P-5-4-5-5,83571.html

    Il m'a d'ailleurs apporté la solution et je l'en remercie:

    Dans le fichier "form/editor/xul/field.xsl" il faut faire la modification suivante :

    Remplacer :

    <xsl:template match="fieldinput">
    <xsl:variable name="elem" select="php:function('uixul_DocumentEditorService::XSLSetDefaultFieldInfo', .)" />
    <xsl:call-template select="$elem" name="fieldInput"/>
    </xsl:template>

    Par :

    <xsl:template match="fieldinput">
    <xsl:call-template select="php:function('uixul_DocumentEditorService::XSLSetDefaultFieldInfo', .)" name="fieldInput"/>
    </xsl:template>

    Par contre, depuis l'installation du fix [FIX #83480] "Incompatibilité avec xsl fix " il m'est impossible de lister les attributs étendus (Boutique -> Attributs) et bien sûr, idem dans les fichiers produits/kit/etc..

    Si qqun a une idée, je prends.

    RBS Change 3.6.3
    PHP 5.4.43

    Merci

    Cdt,
    JC
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1359 membres
Aucun membre connecté