Installation RBS Change : Votre hébergement est incompatible module mod_rewrite non acrivé

  • 26475.1

    27/01/2011 07:22


    Bernard71
    Rang : Nouveau Membre
    Bonjour,

    Tout d'abord merci pour cet exellent CMS, qui sans nulle doute raviera plus d'une boutique en ligne. J'ai télécharger la version e-Commerce Core 3.0.4 hier soir. J'ai donc suivi le mode opératoir d'installation et un message est apparu "Votre hébergement est incompatible".

    Deux erreurs sont apparu:
    - Manque de mémoire
    . Résolu en laissant un message au service technique de Nexen

    - Le module mod_rewrite n'a pas l'air activé. Veuillez activer mod_rewrite
    . J'ai également laissé un message au service technique de nexen et me dise que le est activé
    dont voici la teneur: Le mod_rewrite est activé sur notre plateforme, vous pouvez le vérifier
    grâce au phpinfo.

    apache2handler
    Apache Version Apache
    Apache API Version 20051115
    Server Administrator [no address given]
    Hostname:Port php5info.nexenservices.com:0
    User/Group www-data(33)/33
    Max Requests Per Child: 0 - Keep Alive: on - Max Per Connection: 100
    Timeouts Connection: 300 - Keep-Alive: 15
    Virtual Server Yes
    Server Root /etc/apache2
    Loaded Modules core mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_dir mod_env mod_mime mod_negotiation mod_php5 mod_rewrite mod_setenvif mod_status mod_vhost_alias mod_vhs


    Pouvez-vous m'aider?

    Bernard Desbois
  • 26475.2 en réponse à 26475.1 écrit par Bernard71

    27/01/2011 17:52


    Alexandre Simon
    Titre : Développeur RBS Change
    Rang : Expert
    Bonjour,

    tout d'abord, merci pour les compliments ;)

    La détection en question se base sur le fait que le serveur arrive à télécharger "http://.../install/rewrite_ok", fichier qui n'existe pas et qui est en fait, via mod_rewrite, le fichier "http://.../install/rewrite_ok.php".

    Pouvez-vous vérifier que
    1. "http://.../install/rewrite_ok.php" existe et répond "rewriteOK..."
    2. "http://.../install/.htaccess" existe et contient au moins les lignes suivantes ? :
    <IfModule mod_rewrite.c>
            RewriteEngine on
            RewriteRule ^rewrite_ok$ /install/rewrite_ok.php [QSA,L]
    </IfModule>


    Cordialement,
  • 26475.3 en réponse à 26475.2 écrit par Alexandre Simon

    15/09/2011 18:00


    Alar
    Rang : Nouveau Membre
    Bonjour,

    Je me permet de faire rebondir le sujet, car j'ai le même souci.

    Voilà la seule ligne que je retrouve dans mon fichier rewrite, donc du coup on peut supposer qu'il répond rewriteOK
    echo "rewriteOK".md5((isset($_SERVER["HTTPS"]) ? "on":"")."/".$_SERVER["HTTP_HOST"]."/".dirname(__FILE__));


    Et effectivement, je retrouve dans le fichier htaccess les lignes décrites, pour info:
    <IfModule mod_rewrite.c>
    	RewriteEngine on
    	RewriteRule ^rewrite_ok$ /install/rewrite_ok.php [QSA,L]
    </IfModule>


    Que faire, docteur ?
  • 26475.4 en réponse à 26475.3 écrit par Alar

    17/09/2011 22:08


    Alexandre Simon
    Titre : Développeur RBS Change
    Rang : Expert
    Bonjour,

    pouvez-vous tester l'URL http://nomdomaine.com/install/rewrite_ok (sans .php) ?
  • 26475.5 en réponse à 26475.4 écrit par Alexandre Simon

    08/06/2012 11:23


    bcharfi
    Rang : Adepte
    Bonjour,

    J'ai eu le même problème pour le module mod_rewrite.
    J'ai vérifié aussi que:

    1. "http://.../install/rewrite_ok.php" existe et répond "rewriteOK..."
    2. "http://.../install/.htaccess" existe et contient les lignes suivantes :

    <IfModule mod_rewrite.c>
     RewriteEngine on
     RewriteRule ^rewrite_ok$ /install/rewrite_ok.php [QSA,L]
    </IfModule>

    3. En testant la page rewrite_ok (sans .php), j'obtient ce message : The requested URL /install/rewrite_ok was not found on this server


    Merci en avance,



    RBS Change Version 3.5.2 - eCommerce Core
  • 26475.6 en réponse à 26475.5 écrit par bcharfi

    08/06/2012 11:59


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Pouvez vous regarder à l'adresse :
    http://<votre.domaine.com>/install/phpinfo.php


    et voir si vous avez bien mod_rewrite dans la section Loaded Modules dans la section concernant le serveur Apache (en supposant que ce soit votre serveur HTTP)

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 26475.7 en réponse à 26475.5 écrit par bcharfi

    08/06/2012 12:24


    bcharfi
    Rang : Adepte
    Merci pour votre réponse,

    J'ai résolu le problème en modifiant le paramètre
    AllowOverride None => AllowOverride All dans le fichier httpd.conf d'Apache:

    <Directory "/var/www/html">
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    Il faut vérifier aussi dans ce fichier qu'on a :

    1- LoadModule rewrite_module modules/mod_rewrite.so
    2- <IfModule mod_rewrite.c>
    RewriteEngine On
    </IfModule>

    Édité par bcharfi 08/06/2012 12:25




    RBS Change Version 3.5.2 - eCommerce Core
  • 26475.8 en réponse à 26475.7 écrit par bcharfi

    08/06/2012 14:48


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Très bien, si vous voulez un peu plus d'infos sur l'installation système, vous pouvez toujours regarder dans le wiki la page Change sous Ubuntu Lucid. Certes les informations portent sur la version 3.0, mais la manière d'installer la plateforme n'a pas évoluée en terme de prérequis.

    Édité par Jean-Michel 21/09/2012 11:34


    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 26475.9

    19/07/2013 23:13


    jean-micael
    Rang : Membre
    Pour ceux qui auraient cette erreur au début de l'installation :

    "- Le module mod_rewrite n'a pas l'air activé. Veuillez activer mod_rewrite"

    -> il vous suffit de retirer le # de la ligne LoadModule rewrite_module modules/mod_rewrite.so dans le fichier httpd.conf (clic sur Wamp, puis menu Apache).
  • 26475.10

    16/10/2013 16:34


    d.spitaels@gmail.com
    Rang : Nouveau Membre
    Bonjour,

    J'essaye d'installer change sur un serveur Debian 7/Apache 2/PHP5/MySQL.

    J'ai le message d'erreur précité.

    J'ai vérifié les points cité, mais tout semble OK.

    Avez-vous une idée de l'origine de l'erreur? Peut-être une incompatibilité connue avec ma configuration?

    En vous remerciant d'avance de votre aide.

    Dimitri.
  • 26475.11

    31/01/2014 21:27


    c.charles
    Rang : Membre
    Bonjour,
    Tout d'abord félicitations pour votre travail.
    Convaincu, j'ai suivi le wiki pour une installation de la version Change 3.6.8 mais je rencontre le souci suivant :
    http://XXX/install/index.php me renvoit le message:
    Le module mod_rewrite n'a pas l'air activé. Veuillez activer mod_rewrite ou vous assurer que ces directives peuvent être placées dans un fichier .htaccess
    alors que http://XXX/install/phpinfo.php me donne bien dans la section apache2handler > Loaded Modules :
    core mod_log_config mod_logio mod_version itk http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env mod_expires mod_headers mod_mime mod_negotiation mod_php5 mod_reqtimeout mod_rewrite mod_setenvif mod_status
    et que http://XXX/install/rewrite_ok.php me renvoit bien :
    rewriteOK4ad94f4c3eb3b05cffec4aff09b595ee
    tandis qu'un http://XXX/install/rewrite_ok (sans.php) renvoit (question d'Alexandre Simon):
    une erreur 404 Not Found
    un
    nano /home/rbschange/www/install/.htaccess
    m'a permis de vérifier l'existance d'un .htaccess ainsi que la présence des lignes suivantes dans ce dernier :
    <IfModule mod_rewrite.c>
            RewriteEngine on
            RewriteRule ^rewrite_ok$ /install/rewrite_ok.php [QSA,L]
    </IfModule>

    Après vérification :
    nano /etc/apache2/apache2.conf 
    (pas de httpd.conf sous apache2)
    une recherche de AllowOverride ne renvoit aucune occurance
    Voici la manière dont j'ai géré mon Virtualhost :
    /etc/apache2/sites-available# nano rbs

    <VirtualHost _default_:80>
        ServerName XXX
    
        # User and group used by Apache (Only with mpm-itk)
        AssignUserID rbschange rbschange
    
        ServerAdmin XXX@tXXX
        ## Uncomment line below for Debian, Ubuntu...
        CustomLog /var/log/apache2/rbschange.local.fr.log combined
        ErrorLog /var/log/apache2/rbschange.local.fr.log.error.log
        ## Uncomment line below for RHEL, CentOS....
        #CustomLog /var/log/httpd/rbschange.local.fr_log combined
        #ErrorLog /var/log/httpd/rbschange.local.fr._error_log
        
        # specific types for Change backoffice
        AddType application/x-xpinstall .xpi
        AddType application/vnd.mozilla.xul+xml .xul
        AddType text/xml .rdf .xbl
    
        # Expires header
        <IfModule expires>
            ExpiresActive On
            ExpiresByType image/gif A7200
            ExpiresByType image/png A7200
            ExpiresByType image/jpeg A7200
            ExpiresByType text/css A7200
            ExpiresByType text/javasript A7200
            ExpiresByType application/x-javascript A7200
            ExpiresByType application/x-shockwave-flash A7200
        </IfModule>
        
        # Text data compression
        <IfModule deflate>
            AddOutputFilterByType DEFLATE text/html text/css text/plain text/xml application/x-javascript application/json
            DeflateCompressionLevel 1
            BrowserMatch ^Mozilla/4 gzip-only-text/html
            BrowserMatch ^Mozilla/4.0[678] no-gzip
            BrowserMatch bMSIE !no-gzip !gzip-only-text/html
        </IfModule>
        
        # PHP configuration
        php_flag short_open_tag off
        php_flag magic_quotes_gpc off
        php_value memory_limit 192M
        php_value post_max_size 60M
        php_value upload_max_filesize 60M
        php_value default_charset utf-8
        php_value session.cache_limiter " "
        # You may want to change your sessions path
        php_value session.save_path /home/rbschange/sessions
        
        # Don't forget to modify DocumentRoot value here
        DocumentRoot /home/rbschange/www
        <Directory /home/rbschange/www>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
        </Directory>
    </VirtualHost>


    /etc/apache2/sites-available# 
    Enabling site rbs.
    To activate the new configuration, you need to run:
      service apache2 reload
    /etc/apache2/sites-available# service apache2 reload
    [....] Reloading web server config: apache2Warning: DocumentRoot [/home/rbschange/www] does not exist
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    . ok
    

    Pour ce qui est de ma configuration :
      RBSChange 3.6.8
      Debian 7.3 noyau 2.6.32-19-pve
      Apache 2.2.22
      PHP Version 5.4.4-14+deb7u7
      MySQL Version 5.5.35

    Édité par c.charles 31/01/2014 21:45

  • 26475.12 en réponse à 26475.11 écrit par c.charles

    03/02/2014 08:56


    Loïc Couturier
    Rang : Adepte
    Bonjour Charles,

    Merci pour l'intérêt que vous portez à la solution.

    Puisque la configuration semble correcte, je dirais que le premier soucis à régler est l'erreur que vous avez lorsque vous redémarrez votre serveur Apache.

    [....] Reloading web server config: apache2Warning: DocumentRoot [/home/rbschange/www] does not exist

    Si le vhost ne répond pas correctement vous aurez en cascade d'autres problèmes.

    Revérifier que votre répertoire /home/rbschange/www existe bien.
    Vous devrez également à ce moment avoir tous le code de RBSChange dans ce répertoire.

    Je vous laisse déjà effectuer ces vérifications et revenir vers nous.

    Merci.
  • 26475.13 en réponse à 26475.12 écrit par Loïc Couturier

    03/02/2014 09:46


    c.charles
    Rang : Membre
    Bonjour et merci pour cette réponse rapide,
    Je n'ai plus cette erreur lors du redémarrage d'apache :
    service apache2 restart
    [....] Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    J'ai les fichiers de RBS bien présents dans le répertoire /home/rbschange/www/ et toujours mon souci de mod_rewrite
    Comme cette installation dans /home était inhabituelle pour moi j'ai aussi mis les fichiers rbs dans /var/www/rbs/ en modifiant le vhost en conséquence et avec un # chown -R rbschange:rbschange /var/www/rbs/
    et toujours la même chose... alors qu'après vérifications le mod_rewrite semble bien activé :
    # a2enmod rewrite
    Module rewrite already enabled
    # updatedb
    # a2enmod rewrite

    et
    # cd /etc/apache2/mods-enabled/
    # nano rewrite.load

    donne bien la ligne :
    LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so
    d'autres part j'ai édité dans /etc/apache2/sites-enabled/000-default et /etc/apache2/sites-available/default et je me suis bien assuré de mettre AllowOverride All mais sans succès...
    Merci d'avance pour votre retour
  • 26475.14 en réponse à 26475.13 écrit par c.charles

    04/02/2014 10:42


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Un petit souvenir d'une installation avec un Apache 2.2 un peu plus récent que celui disponible dans Ubuntu 12.04.

    Il m'était arrivé le même genre de problème, avec une configuration correcte etc... sauf que le mod_rewrite était indiqué comme inexistant alors que pourtant...
    Après des recherches pour comprendre ce qu'il se passait et à loguer dans tous les sens, j'ai pu trouver un message (dont je ne me souviens plus) qui m'a permis d'entrevoir la solution au problème ; une modification de l'algorithme d'Apache sur la négociation de contenu lorsque la directive MultiViews est présente.
    En principe maintenant la directive MultiViews peut être retirée de la configuration du vhost. Je vous invite à faire le test en retirant cette directive et en redémarrant Apache.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 26475.15 en réponse à 26475.14 écrit par Jean-Michel

    04/02/2014 17:13


    c.charles
    Rang : Membre
    Bonsoir,
    Excellent souvenir Apache 2.2 Jean-Michel !
    En effet après un
    # nano /etc/apache2/sites-available/rbs

    une mise en commentaire de la ligne indiquée :
    DocumentRoot /home/rbschange/www
    <Directory /home/rbschange/www>
    # Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    et un redémarrage apache :
    # service apache2 restart

    je parviens enfin à l'étape 2 ! :-)
    Mon problème est donc résolu, espérant que mon retour d'expérience puisse servir à d'autres.
  • 26475.16

    04/02/2014 17:40


    c.charles
    Rang : Membre
    Re-bonsoir,
    Nouveau problème à l'étape 2 avec le message :
    Imposible de créer le lien symbolique /home/rbschange/www/repository/framework/framework-3.6.8 -> /home/rbschange/www/framework
    J'ai tenté un :
    # ln -s /home/rbschange/www/repository/framework/framework-3.6.8  /home/rbschange/www/framework
    # service apache2 restart

    mais sans succès...
    Une idée ?
    Merci

    Édité par c.charles 04/02/2014 17:56

  • 26475.17 en réponse à 26475.16 écrit par c.charles

    04/02/2014 22:58


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonsoir,

    Supprimez juste le MultiViews, les autres sont me semble-t-il utiles. Par contre pour le symlink de framework, vérifiez qu'il n'existe pas déjà ; l'erreur peut être liée à cela. Dans le doute vous pouvez faire en toute tranquillité un
    find . -type l -exec rm -f {} \;

    Afin de supprimer tous les liens symboliques qui pourraient déjà exister.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1378 membres
Aucun membre connecté