RBS Change 3.7 compatible avec PHP 7.2

Écrit par RBS Change - 11/10/2018 06:00
La première version stable de PHP 7 est désormais disponible depuis un peu moins de 2 ans, offrant à ce jour une version stable 7.2, intégrant les optimisations de performances de PHP7, ainsi que de nombreuses améliorations des 2 versions stables précédentes.

De plus, cette version PHP 7.2 bénéficie d'un support actif jusqu'à fin 2019 (correctifs de bugs) et de sécurité jusqu'à fin 2020.

Nous avons aujourd'hui le plaisir de vous annoncer la compatibilité de la version (en bêta) 3.7 de RBS Change, compatible avec PHP 7.2.

Les benchmarks réalisés sur une version e-commerce native de RBS Change font apparaître un gain allant jusqu'à -50% sur le temps de rendu des pages, en comparaison avec la version 3.6 sous PHP 5.

A noter que bien que le code PHP 5 soit quasi-intégralement compatible avec PHP 7, il pourra être nécessaire d'adapter des développements spécifiques.

Cette nouvelle version peut d'ores et déjà être testée ici : https://github.com/RBSChange/Change/tree/3.7.

Vous souhaitez migrer votre projet RBS Change 3.6 existant vers PHP 7 ? Contactez-nous à rbschange@clickandmortar.fr

Rappel : avant toute mise à jour, il est impératif de faire une sauvegarde de votre système.

En cas de problèmes ou de questions, merci d'utiliser les Forums.

L'équipe RBS Change

Laissez un commentaire

Les commentaires sont fermés pour ce billet.

 
1426 membres
Aucun membre connecté