Release

  1. Découvrez RBS Change sans effort grâce à la VM

    Écrit par Jean-Michel Ramseyer - 07/05/2013 15:30 - Aucun commentaire

    Disposez facilement d'un environnement RBSChange entièrement configuré pour tester et développer...
  2. RBS Change 3.5.10 et 3.6.5 disponibles au téléchargement

    Écrit par RBS Change - 02/05/2013 09:21 - Aucun commentaire

    Les versions correctives pour RBS Change 3.5 et 3.6 sont maintenant disponibles.
    Il s'agit de mises à jour mineures.

    Version 3.5.10 :
    Version 3.6.5 :
    Vous trouverez deux installeurs web pour la version majeure courante (3.6.5) contenant :
    - Les modules open source minimum : RBS Change Core
    - Tous les modules open source : RBS Change complet - Open Source

    A noter : Les installeurs sont faits pour fonctionner avec 128 Mo de RAM. Cependant nous avons remarqué qu'en fonction des plateformes et de la configuration de PHP et/ou Apache, des erreurs de mémoires peuvent apparaître.

    Pour effectuer la mise à jour vers la version 3.6.5 depuis la version 3.6.4, vous disposez de 3 solutions :

    La première, recommandée, en passant par la ligne de commande ou la console web :
    - Exécuter la commande updater.migrate download : téléchargement des nouveaux packages et vérification du projet
    - Exécuter la commande updater.migrate apply : Mise à jour du projet

    La seconde en faisant une migration manuelle :
    - Télécharger la librairie de migration :
    Version 3.5.10 : http://update.rbschange.fr/libs/migration/migration-3.5.10.zip
    Version 3.6.5 : http://update.rbschange.fr/libs/migration/migration-3.6.5.zip
    - Décompresser dans le dossier migration à la racine du site
    - En vous plaçant à la racine du projet exécuter : php migration/migrate.php

    La dernière, déconseillée suite à la découverte d'un comportement aléatoire sur certains serveurs Apache, en utilisant l'interface backoffice du module Mise à jour.

    Important :
    Une fois la mise à jour terminée la variable de configuration modules/website/useBeanPopulateStrictMode est définie à false pour éviter tout potentiel problème avec vos développements spécifiques. Il faudra donc bien vérifier le fonctionnement des formulaires utilisant la mécanique de bean.
    Pour sécuriser vos sites vous devez repasser cette variable à true et vérifier votre fonctionnel spécifique.


    Rappel : avant toute mise à jour, il est impératif de faire une sauvegarde de votre système.

    En cas de problèmes ou de questions, merci d'utiliser les Forums.

    L'équipe RBS Change
  3. Accès backoffice et Firefox

    Écrit par Jean-Michel Ramseyer - 14/03/2013 14:53 - Aucun commentaire

    Comme je l'ai indiqué dans mon dernier billet "Crash Firefox 17 et +, qu'en est-il ?" nous avons continué nos sollicitations auprès de Mozilla pour fixer le bug 813897 qui empêchait l'accès au backoffice, et c'est avec plaisir que je vous annonce que le bug est corrigé et la correction sera bientôt disponible.

    Vous l'avez peut-être lu, j'ai testé le fix via Firefox nightly. Le premier constat était positif et nous a permis de corriger les points relatifs à l'évolution de Firefox. Depuis j'utilise Firefox nightly sans difficulté avec le backoffice.
    Ainsi, même si vous attendez les versions de Firefox intégrant le correctif, vous pourrez vous connecter au backoffice, mais il ne sera pas totalement opérationnel ; il vous faudra modifier votre installation de RBSChange de sorte à mettre à jour le module uixul.


    Quelles versions de Firefox?

    Les versions actuelles n'intègrent pas encore le fix, il sera en principe dans les prochaines versions/release indiquées ci-après :
    • Firefox 17 ESR
    • Firefox 20
    • Firefox 21
    • Firefox 22 et suivants


    Quelles modifications dans RBSChange?

    Pour pouvoir profiter d'une version de Firefox corrigeant le bug, nous avons dû modifier le backoffice pour retirer une couche de compatibilité avec les anciennes versions de Firefox. La mise à jour de votre installation RBSChange pour accéder à votre backoffice est simple ;

    • soit vous attendez la prochaine release qui intégrera la modification du module uixul
    • soit vous mettez à jour 3 bindings  dans l'override du module uixul de votre projet en attendant la prochaine release. Demandez à votre prestataire de regarder le commit 1f174d7fa306f6ec6998040880ea9042a5e5b71d avant de faire la modification.


    Si vous avez besoin de tester votre backoffice après la mise en œuvre des bindings, vous pouvez utiliser Firefox nightly

    RAPPEL : Firefox nightly n'est à utiliser qu'à des fins de test.

    Si vous ne souhaitez pas mettre à jour pour l'instant et continuer avec Firefox 10 ESR, dans ce cas ces liens de téléchargement sont disponibles dans l'article "Crash Firefox 17 et +, qu'en est-il ?"
  4. RBS Change 3.5.9 et 3.6.4 disponibles au téléchargement

    Écrit par RBS Change - 30/01/2013 10:00 - 3 commentaires

    Les versions correctives pour RBS Change 3.5 et 3.6 sont maintenant disponibles.
    Il s'agit de mises à jour mineures.

    Version 3.5.9 :
    Version 3.6.4 :
    • Corrections d'une liste de tickets
    • Amélioration du sélectionneur de date du module formulaire (définition possible d'une plage)
    • Mise en place d'une tâche planifiée pour la génération des numéros de commandes, factures, expéditions, ordres de préparation et avoirs (voir 60779 - Doublon numéro de commande). La migration conserve le fonctionnement de la version 3.6.3. Vous trouverez ci-essous l'explication vous permettant de bénéficier de cette amélioration
    • Amélioration du module d'exemple (sample) permettant de générer un site de démonstration
    Vous trouverez deux installeurs web pour la version majeure courante (3.6.4) contenant :
    - Les modules open source minimum : RBS Change Core
    - Tous les modules open source : RBS Change complet - Open Source

    A noter : Les installeurs sont faits pour fonctionner avec 128 Mo de RAM. Cependant nous avons remarqué qu'en fonction des plateformes et de la configuration de PHP et/ou Apache, des erreurs de mémoires peuvent apparaître.

    Pour effectuer la mise à jour vers la version 3.6.4 depuis la version 3.6.3, vous disposez de 3 solutions :

    La première, recommandée, en passant par la ligne de commande ou la console web :
    - Exécuter la commande updater.migrate download : téléchargement des nouveaux packages et vérification du projet
    - Exécuter la commande updater.migrate apply : Mise à jour du projet

    La seconde en faisant une migration manuelle :
    - Télécharger la librairie de migration :
    Version 3.5.9 : http://update.rbschange.fr/libs/migration/migration-3.5.9.zip
    Version 3.6.4 : http://update.rbschange.fr/libs/migration/migration-3.6.4.zip
    - Décompresser dans le dossier migration à la racine du site
    - En vous plaçant à la racine du projet exécuter : php migration/migrate.php

    La dernière, déconseillée suite à la découverte d'un comportement aléatoire sur certains serveurs Apache, en utilisant l'interface backoffice du module Mise à jour.

    Par défaut, l'installation de la mise à jour ne change pas le fonctionnel de la partie numérotation.
    Pour activer la numérotation différée, il vous faudra modifier votre fichier de configuration afin de supprimer l'entrée delayNumberGeneration puis recompiler la configuration avec la commande compile-config.

    Rappel : avant toute mise à jour, il est impératif de faire une sauvegarde de votre système.

    En cas de problèmes ou de questions, merci d'utiliser les Forums.

    L'équipe RBS Change
  5. RBS Change 3.5.8 et 3.6.3 disponibles au téléchargement

    Écrit par RBS Change - 26/11/2012 17:20 - 2 commentaires

    Les versions correctives pour RBS Change 3.5 et 3.6 sont maintenant disponibles.
    Il s'agit de mises à jour mineures.

    Version 3.5.8 :
    Version 3.6.3 :
    Vous trouverez deux installeurs web pour la version majeure courante (3.6.3) contenant :
    - Les modules open source minimum : RBS Change Core
    - Tous les modules open source : RBS Change complet - Open Source


    Pour effectuer la mise à jour, vous disposez de 3 solutions :

    La première, recommandée, en passant par la ligne de commande ou la console web :
    - Exécuter la commande updater.migrate download : téléchargement des nouveaux packages et vérification du projet
    - Exécuter la commande updater.migrate apply : Mise à jour du projet

    La seconde en faisant une migration manuelle :
    - Télécharger la librairie de migration :
    Version 3.5.8 : http://update.rbschange.fr/libs/migration/migration-3.5.8.zip
    Version 3.6.3 : http://update.rbschange.fr/libs/migration/migration-3.6.3.zip
    - Décompresser dans le dossier migration à la racine du site
    - En vous plaçant à la racine du projet exécuter : php migration/migrate.php

    La dernière, déconseillée suite à la découverte d'un comportement aléatoire sur certains serveurs Apache, en utilisant l'interface backoffice du module Mise à jour.

    Après le passage en version 3.6.3, un patch du module RSS reste applicable. Ce patch sert à rendre disponible l'ancien bloc de détail des flux RSS. Il n'est pas conseillé de l'appliquer.

    Si vous ne l'appliquez pas, vous pouvez initialiser la liste des patchs en exécutant la commande : init-patch-db

    Rappel : avant toutes mises à jour, il est impératif de faire une sauvegarde de votre système.

    En cas de problèmes ou de questions, merci d'utiliser les Forums.

    L'équipe RBS Change

 
1433 membres
Aucun membre connecté