Développer avec RBS Change : Mediathèque : traduction et éditeurs

  • 81386.1

    15/10/2013 00:44


    Mathias
    Rang : Expert
    Bonjour,

    je suis face à une situation assez inédite :
    Au sein du module médiathèque, lorsque j'essaye d'éditer le contenu d'un media, l'éditeur principal n'est pas positionné sur ma langue de travail.
    Je m'explique :
    - Mon projet a 2 langues, Français et Anglais
    - Mon BO est configuré pour travailler sur la langue de travail "Français" (Outils > choisir ma langue de travail)
    - Lorsque j'édite un fichier de ma médiathèque :
    - l'éditeur principal (onglet propriété) édite la langue anglaise,
    - l'onglet traduction propose de traduire en Français à partir de l'anglais (c'est logique par rapport à l'onglet propriétés)
    - Seul le module médiathèque s'entremêle les pinceaux : le module site & pages, ou encore "Texte statique" respectent bien la langue de travail choisie.
    - A savoir que j'ai dupliqué mon projet sur 3 environnements différents (dev, inté, prod) et je retrouve ce problème sur les différents env...
    [UPDATE]
    - mes medias sont rangés en sous-dossiers, la perspective qui liste les médias du sous dossier m'affiche comme libellé le libellé Anglais.
    - tous les sous dossiers ne sont pas logés à la même enseigne, d'autres sous-dossier avec des medias jamais traduits ne posent aucun problèmes
    ----
    Du coup je redoute un cafouillage avec la commande change.php i18n-synchro, mais c'est tout de même assez étrange de se retrouver dans une telle situation...
    ------
    [/UPDATE]

    Mon projet utilise la synchronisation et mon fichier project.xml contient l'entrée suivante :
    <config>
        <i18nsynchro>
          <entry name="en">fr</entry>
        </i18nsynchro>
      </config>


    Avez vous une idée d'où cela peut-il venir ?

    ps : je n'ai pas de traces dans les logs particulières lorsque j'édite les médias...

    Édité par Mathias 15/10/2013 00:56


    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 81386.2 en réponse à 81386.1 écrit par Mathias

    25/10/2013 15:01


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour Mathias,

    Je voudrais juste une précision ; au moment de se connecter au BO, sur quelle langue est positionnée la liste déroulante ?

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 81386.3 en réponse à 81386.2 écrit par Jean-Michel

    25/10/2013 17:53


    Mathias
    Rang : Expert
    Hello Jean Michel,

    après vérification, aucune langue n'était settée dans la popup de login.
    Par contre, l'url du backoffice se termine bien après login avec le paramètre &uilang=fr.
    J'ai forcé la langue à FR et j'ai toujours le même problème...

    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1442 membres
Aucun membre connecté