Développer avec RBS Change : bug de génération des images ?

  • 83852.1

    30/06/2014 15:17


    seb
    Rang : Expert
    Bonjour,
    J'héberge plusieurs site chez OVH (heb mutualisé).
    Tout fonctionnait très bien jusqu'alors, mais depuis quelques jour, les images générées par RBS Change (glissé déposé dans du contenu) s'affichent correctement en backoffice, mais plus en front office.
    J'ai un message du type "Forbidden
    You don't have permission to access /publicmedia/formatted/141/80/fr/monimage-petit.jpg;maxh=65,maxw=100,h=65,w=100.jpg on this server.
    "
    Quelqu'un a déjà eu ce souci ?
    Je suppose fortement une mise à jour serveur du côté d'OVH, mais je n'ai pas les compétences pour trouver un contournement à cela.

    Des idées pour résoudre mon souci?
  • 83852.2 en réponse à 83852.1 écrit par seb

    30/06/2014 17:03


    Mathias
    Rang : Expert
    Ca semble est simplement une erreur de droit sur les dossiers/fichiers.

    As tu essayé la commande "apply-project-policy" et "apply-webapp-policy" ?

    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 83852.3 en réponse à 83852.2 écrit par Mathias

    02/07/2014 12:21


    seb
    Rang : Expert
    Hello
    Oui, j'ai déjà essayé.
    J'ai d'ailleurs l'erreur :
    Warn on Apply 'cache' dir policy: SplFileInfo::getOwner() [<a href='splfileinfo.getowner'>splfileinfo.getowner</a>]: stat failed for cache/default/simplecache/registration/byDocId/130/42/5/6/3/website_BlockThreadAction_5632445667afb236f92dcc2ba757ce38

    qui apparait lorsque je fais un apply-project-policy.

    J'ai ensuite regardé du côté de l'hébergeur... http://travaux.ovh.net/?do=details&id=10981 : je pense que c'est lié à cela :
    --> Change génère des liens symboliques qui pointent dans le dossier publicmedia/original dès lors qu'il n'y a pas de redimensionnement d'image. C'est en fait ce lien là qui n'a plus les bons droits.
    --> Les images s'affichent lorsque je les redimensionne car elles sont générées directement dans publicmedia/formatted/ID1/ID2/fr/ sans générer de lien symbolique.

    Du coup, j'ai modifié le fichier change.properties (homez.428/projet/www/repository en home/projet/..... )

    y a t il d'autres endroit à changer ?

    Je ne vois pas trop comment faire pour le coup, à part harceler l'hébergeur.
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1425 membres
Aucun membre connecté