Installation RBS Change : PAS DE REPONSE

  • 57402.1

    30/04/2012 01:12


    ch4d
    Rang : Membre
    Sa fait 3 ou 4 jours que je n'est pas de réponse de la part des technicien de rbschange, au sujet de l'installation du cms lors de l'installation il me dit cela :
    http://ch4d.kyronet.com/install/index.php
    c'est assez embarrassant et cela me fait perdre du temps étant donné que j'ai installer toute les extensions, et les modules apache sont activé je ne vois pas mes erreurs au finale.

    Cordialement
  • 57402.2 en réponse à 57402.1 écrit par ch4d

    30/04/2012 11:20


    guiom
    Rang : Expert
    Bonjour,

    La société RBS propose un support gratuit via ce forum, si vous souhaitez un support rapide vous pouvez souscrire un contrat de support. Je ne connais pas leur offre, mais peut-être proposent-ils d'intervenir les WE et jour fériés ?

    Pour en revenir à votre problème, les messages d'erreurs me semble suffisant explicite :
    * Vous devez autoriser l'écriture sur les dossiers et fichiers indiqués. En ligne de commande :
    chmod +w /var/www/clients/client1/web1/web
    chmod +w /var/www/clients/client1/web1/web/change.xml
    chmod +w /var/www/clients/client1/web1/web/change.properties
    chmod +w /var/www/clients/client1/web1/web/config/project.default.xml
    Vous pouvez aussi réaliser cette opération via votre client FTP.

    * Vous devez installer et activer les modules php curl et xsl. D'apres votre phpinfo, vous etes sur un debian, voici la commande à lancer en root :
    apt-get install php5-curl php5-xsl
  • 57402.3 en réponse à 57402.1 écrit par ch4d

    30/04/2012 11:59


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Vous postez dans les forums communautaires de RBSChange, en conséquent les techniciens ne répondent que lorsque la communauté ne peut fournir de réponse, et pendant les heures ouvrées, nous n'avons pas d'engagement sur le délai dans les forums.

    Vous avez posté samedi 28, nous sommes lundi 30 et je constate qu'il vous manque toujours des extensions comme l'indique la page de l'installeur (http://ch4d.kyronet.com/install/index.php):
      * l'extension [curl] n'est pas installée
      * l'extension [xsl] n'est pas installée 


    Par ailleurs, il reste encore des problèmes avec les droits d'écriture sur certains fichiers :
    * le dossier [/var/www/clients/client1/web1/web] n'est pas accessible en écriture 
    * le fichier [/var/www/clients/client1/web1/web/change.xml] n'est pas accessible en écriture
    * le fichier [/var/www/clients/client1/web1/web/change.properties] n'est pas accessible en écriture
    * le fichier [/var/www/clients/client1/web1/web/config/project.default.xml] n'est pas accessible en écriture


    Je ne sais pas comment vous conseiller ignorant vos habitudes de travail et votre niveau de maîtrise de l'environnement serveur. D'après ce que je vois vous fonctionnez sous Debian avec Apache et FCGI, ce qui signifie que le groupe et l'utilisateur Apache vaut www-data (sauf si vous l'avez modifié pour ce vhost en particulier), donc soit vous donnez à cet utilisateur les droits d'écriture sur les fichiers et dossiers indiqués, soit vous le rendez propriétaire (récursivement) du DocumentRoot et ce devrait être suffisant.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57402.4 en réponse à 57402.3 écrit par Jean-Michel

    30/04/2012 18:42


    ch4d
    Rang : Membre
    merci beaucoup à vous deux de m'avoir éclairer, aujourd'hui les problème sont presque tous résolut mais j'aurai vraiment passé beaucoup de temps pour l'installation d'un CMS

    Merci beaucoup Cordialement Chadhliyy
  • 57402.5

    30/04/2012 18:43


    ch4d
    Rang : Membre
    juste pour information ce qui me reste c'est permettre la fabrication de lien symbolique donc je cherche sur google en attendant si vous avez une solution à me proposé merci beaucoup

    Cordialement
  • 57402.6

    30/04/2012 20:46


    ch4d
    Rang : Membre
    tout est bon il me manque simplement cette erreur -là :
    Votre configuration comporte des erreurs. Veuillez les corriger.
    - Le fichier /var/www/clients/client1/web1/web/install/configdatas.php n'a pu être écrit.
  • 57402.7 en réponse à 57402.6 écrit par ch4d

    02/05/2012 09:17


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Pareil un problème de permission au niveau du filesystem.
    * Soit vous donnez les droits d'écriture complet au serveur Apache au niveau du dossier racine de votre serveur web :
    chmod -R +w /var/www/clients/client1/web1/web


    * Soit vous créez et donnez les droits d'écriture sur le fichier
    touch  /var/www/clients/client1/web1/web/install/configdatas.php
    chmod -R +w /var/www/clients/client1/web1/web/install/configdatas.php


    Personnellement, ne connaissant pas l'état des droits et permissions sur votre serveur et dans un souci de simplicité j'utiliserai la première option.

    Édité par Jean-Michel 02/05/2012 09:34


    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57402.8 en réponse à 57402.7 écrit par Jean-Michel

    03/05/2012 02:38


    ch4d
    Rang : Membre
    je veux bien donner tout les droit d'acces au serveur apache mais comment faire car j'ai tous fait j'ai mis dans ma config de apache en root www-data dans les deux option, alors maintenant je ne sais pas quoi faire
  • 57402.9 en réponse à 57402.8 écrit par ch4d

    03/05/2012 09:46


    guiom
    Rang : Expert
    Bonjour,

    Vous vous méprenez, ce n'est pas apache qui doit avoir tous les droits (surtout pas mettre root pour la directive user), mais simplement autoriser l'utilisateur attribuer à apache (généralement www-data sur debian) à réaliser toutes les modifications sur les dossiers d'installation de RBSChange. En général, on affecte le propriétaire et le groupe de apache aux fichiers du site.
    Voici la commande pour changer le propriétaire/groupe :
    chown -R www-data:www-data /var/www/clients/client1/web1/web

    Dans ce cas, vous devez avoir dans la configuration d'apache
    user www-data
    group www-data

  • 57402.10 en réponse à 57402.8 écrit par ch4d

    03/05/2012 14:30


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Je complète les propos de guiom en indiquant qu'il ne faut pas lancer les commandes shell avec l'utillisateur root, mais soit avec l'utilisateur Apache, soit avec l'utilisateur auquel appartient le DocumentRoot, cela dépendant de votre configuration.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57402.11 en réponse à 57402.10 écrit par Jean-Michel

    03/05/2012 23:03


    ch4d
    Rang : Membre
    dans ma config apache ce trouvant dans : etc/apache2/envvars
    le user et le groupe on bien comme configuration www-data
  • 57402.12

    03/05/2012 23:51


    ch4d
    Rang : Membre
    j'ai installer quelque extension mais il me semble que cela viens de extensions dans mon fichier php.ini j'ai mi :
    extension_dir = "/etc/php5/"
    extension=posix.so
    extension=reflection.so
    extension=spl.so
    extension=pdo.so
    extension=pdo_mysql.so
    extension=dom.so
    extension=xmlreader.so
    extension=xmlwriter.so
    extension=simplexml.so
    extension=xsl.so
    extension=mbstring.so
    extension=iconv.so
    extension=imagick.ini
    extension=curl.so

    mais dans les log apache2 il me dit qu'il ne les trouvent pas
  • 57402.13 en réponse à 57402.12 écrit par ch4d

    03/05/2012 23:54


    ch4d
    Rang : Membre
    Voici mes dernier log apache2 :


    [Thu May 03 21:30:03 2012] [error] [client ::1] client denied by server configuration: /var/www/clients/client1/web1/web/
    [Thu May 03 21:35:03 2012] [error] [client ::1] client denied by server configuration: /var/www/clients/client1/web1/web/
    [Thu May 03 21:40:04 2012] [error] [client ::1] client denied by server configuration: /var/www/clients/client1/web1/web/
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/posix.so' - /usr/lib/php5/20090626+lfs/posix.so: cannot open shared object file: No such f$
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/reflection.so' - /usr/lib/php5/20090626+lfs/reflection.so: cannot open shared object file:$
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/spl.so' - /usr/lib/php5/20090626+lfs/spl.so: cannot open shared object file: No such file $
    PHP Warning: PHP Startup: Unable to load dynamic library '/etc/php5/conf.d/pdo.ini' - /etc/php5/conf.d/pdo.ini: invalid ELF header in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/etc/php5/conf.d/pdo_mysql.ini' - /etc/php5/conf.d/pdo_mysql.ini: invalid ELF header in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/dom.so' - /usr/lib/php5/20090626+lfs/dom.so: cannot open shared object file: No such file $
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/xmlreader.so' - /usr/lib/php5/20090626+lfs/xmlreader.so: cannot open shared object file: N$
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/xmlwriter.so' - /usr/lib/php5/20090626+lfs/xmlwriter.so: cannot open shared object file: N$
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/simplexml.so' - /usr/lib/php5/20090626+lfs/simplexml.so: cannot open shared object file: N$
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/mbstring.so' - /usr/lib/php5/20090626+lfs/mbstring.so: cannot open shared object file: No $
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/iconv.so' - /usr/lib/php5/20090626+lfs/iconv.so: cannot open shared object file: No such f$
    PHP Warning: PHP Startup: Unable to load dynamic library '/etc/php5/conf.d/imagick.ini' - /etc/php5/conf.d/imagick.ini: invalid ELF header in Unknown on line 0
    PHP Warning: Module 'xsl' already loaded in Unknown on line 0
    PHP Warning: Module 'curl' already loaded in Unknown on line 0
    PHP Warning: Module 'xsl' already loaded in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/posix.so' - /usr/lib/php5/20090626+lfs/posix.so: cannot open shared object file: No such f$
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/reflection.so' - /usr/lib/php5/20090626+lfs/reflection.so: cannot open shared object file:$
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/spl.so' - /usr/lib/php5/20090626+lfs/spl.so: cannot open shared object file: No such file $
    PHP Warning: PHP Startup: Unable to load dynamic library '/etc/php5/conf.d/pdo.ini' - /etc/php5/conf.d/pdo.ini: invalid ELF header in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/etc/php5/conf.d/pdo_mysql.ini' - /etc/php5/conf.d/pdo_mysql.ini: invalid ELF header in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/dom.so' - /usr/lib/php5/20090626+lfs/dom.so: cannot open shared object file: No such file $
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/xmlreader.so' - /usr/lib/php5/20090626+lfs/xmlreader.so: cannot open shared object file: N$
    PHP Warning: Module 'xsl' already loaded in Unknown on line 0
    PHP Warning: Module 'curl' already loaded in Unknown on line 0
    PHP Warning: Module 'xsl' already loaded in Unknown on line 0
    [Thu May 03 21:45:03 2012] [error] [client ::1] client denied by server configuration: /var/www/clients/client1/web1/web/
    [Thu May 03 21:50:03 2012] [error] [client ::1] client denied by server configuration: /var/www/clients/client1/web1/web/


  • 57402.14

    04/05/2012 01:12


    ch4d
    Rang : Membre
    si je vous donne les login et mot de pass vous Jean-Michel pouvais vous me réglé les problème de configuration?
  • 57402.15 en réponse à 57402.14 écrit par ch4d

    04/05/2012 10:35


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour ch4d,

    Avez-vous suivi les instructions de la page wiki Change sous Ubuntu Lucid? En principe en suivant les instructions données dans cette page, vous devriez réussir à avoir un serveur opérationnel.

    Ubuntu est une distribution dérivée de Debian, les commandes sont les mêmes sauf peut-être "aptitude install" qui peut être remplacé par "apt-get install".

    Par ailleurs, concernant les extensions, les avez-vous installées par "apt-get" ou "aptitude"? Redémarrer le serveur Apache après avoir déclaré les extensions dans le fichier php.ini n'est pas suffisant pour qu'elles soient installées (d'après le log Apache des extensions sont absentes du serveur et d'autres sont chargées à de multiples reprises).

    Sans contrat de support, je ne peux me connecter à votre serveur pour inspecter la configuration et faire le nécessaire en cas de besoin. Je ne peux me permettre d'engager la responsabilité de l'éditeur sans un cadre minimum.
    Toutefois, si un membre de la communauté souhaite vous apporter son aide, cela ne me pose aucun problème. J'accepte également de vous mettre en contact direct par mail avec la personne qui accepterait de vous aider.

    ATTENTION : Pour des raisons évidentes de sécurité, je vous invite à ne pas poster dans les forums les données d'accès à votre serveur (pas de login et pas de mot de passe)

    Édité par Jean-Michel 04/05/2012 10:47


    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57402.16 en réponse à 57402.15 écrit par Jean-Michel

    04/05/2012 17:50


    ch4d
    Rang : Membre
    oui je désire bien que vous me métiez en relation avec un membre du forum qui à les aptitude à réglé mon serveur pour que rbschange puise être installer merci de votre collaboration
    Cordialement
  • 57402.17 en réponse à 57402.16 écrit par ch4d

    07/05/2012 14:11


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Ce sera que si quelqu'un se manifeste dans ce post.

    En attendant vous n'avez pas répondu ; avez vous suivi les instructions de la page wiki?

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57402.18 en réponse à 57402.17 écrit par Jean-Michel

    07/05/2012 18:02


    ch4d
    Rang : Membre
    je ne suis pas sous ubuntu lucid un truc comme cela mais je suis sous debian et lorsque j'ai commencé à suivre certaines de ses instruction j'arrive un moment au sa bloque

    Donc vraiment là c'est pas facile de l'installer ce cms mais je veux vraiment l'utiliser donc sa fait au moins 3 semaine que je regarde
  • 57402.19 en réponse à 57402.18 écrit par ch4d

    07/05/2012 18:13


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Vous pouvez toujours m'indiquer sur quel point Debian vous bloque dans cette procédure.

    Ubuntu est une distribution descendante de Debian, les écarts ne sont pas bien grands ; la plupart du temps il s'agit d'un écart entre les noms des packages ou de petites options de configuration, mais jamais rien de bien méchant. Je suppose que vous êtes sur une Debian Squeeze (v6.0.4)?

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57402.20 en réponse à 57402.17 écrit par Jean-Michel

    09/05/2012 10:44


    guiom
    Rang : Expert
    Bonjour,

    Si vous avez encore besoin d'une aide, je veux bien vous donner un coups de main pour l'installation de RBS Change.

    Jean-Michel, merci de nous mettre en relation.
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1461 membres
Aucun membre connecté