Mises à jour RBS Change : [Résolu] Migration 3.5.2 vers 3.5.5

  • 71982.1

    12/12/2012 11:33


    bcharfi
    Rang : Adepte
    Bonjour,

    J'ai fait une migration d'un site en version 3.5.2 vers 3.5.3 sans probléme.
    En passant de 3.5.3 vers 3.5.4, le fichier change.xml devient comme suit:
    .....
    <dependencies>
        <framework>3.5.4</framework>
        <modules>
          <module>abstractdirectory-3.5.4</module>
          <module>brand-3.5.4</module>
          <module>catalog-3.5.4</module>
          <module>contactcard-3.5.4</module>
          <module>customer-3.5.4</module>
          <module>dashboard-3.5.4</module>
          <module>emailing-3.5.2</module>
          <module>form-3.5.4</module>
          <module>generic-3.5.4</module>
          <module>list-3.5.4</module>
          <module>mailbox-3.5.4</module>
          <module>mapping-3.5.4</module>
          <module>markergas-3.5.4</module>
          <module>marketing-3.5.2</module>
          <module>rss-3.5.4</module>
          <module>notification-3.5.4</module>
          <module>order-3.5.4</module>
          <module>preferences-3.5.4</module>
          <module>shipping-3.5.4</module>
          <module>skin-3.5.4</module>
          <module>solrsearch-3.5.4</module>
          <module>task-3.5.4</module>
          <module>uixul-3.5.4</module>
          <module>useractionlogger-3.5.4</module>
          <module>users-3.5.4</module>
          <module>website-3.5.4</module>
          <module>workflow-3.5.4</module>
          <module>zone-3.5.4</module>
          <module>theme-3.5.4</module>
          <module>ecomextended-3.5.2</module>
          <module>payment-3.5.4</module>
          <module>comment-3.5.4</module>
          <module>filter-3.5.4</module>
          <module>media-3.5.4</module>
          <module>i18n-3.5.4</module>
          <module>sharethis-3.5.4</module>
          <module>seo-3.5.4</module>
          <module>productreturns-3.5.2</module>
          <module>dashstat-3.5.2</module>
          <module>ecomwebservices-3.5.2</module>
          <module>highlight-3.5.2</module>
          <module>synchronizer-3.5.2</module>
          <module>productexporter-3.5.2</module>
          <module>spreadbutton-3.5.2</module>
          <module>featurepackb-3.5.4</module>
          <module>updater-3.5.4</module>
        </modules>
      </dependencies>
    </change>
    


    => il y a des modules qui sont restés en version 3.5.2.

    Losque j'ai lancé la commande updater.migrate refresh, j'obtient :
    => Upgrade available: 3.5.5

    Puis la commande : updater.migrate download , donne :

    Upgrade succefully installed in repository
    Migration script is installed localy
    Download framework from : http://update.rbschange.fr/framework/framework-3.5.5.zip
    Use ZipArchive for unzip: /home/bcharfi/zannier/shared/repository/tmp/framework-3.5.5.zip
    ERROR: Unable to upgrade dashstat-3.5.2
    ERROR: Unable to upgrade ecomextended-3.5.2
    ERROR: Unable to upgrade ecomwebservices-3.5.2
    ERROR: Unable to upgrade emailing-3.5.2
    ERROR: Unable to upgrade marketing-3.5.2
    ERROR: Unable to upgrade productexporter-3.5.2
    ERROR: Unable to upgrade productreturns-3.5.2
    ERROR: Unable to upgrade spreadbutton-3.5.2
    ERROR: Unable to upgrade synchronizer-3.5.2
    ERROR: Error in license file: /home/bcharfi/zannier/kidiliz.local.com/migration/license.xml , OpenSource license.
    ERROR: Invalid license for dashstat: OpenSource license.
    ERROR: Invalid license for ecomextended: OpenSource license.
    ERROR: Invalid license for ecomwebservices: OpenSource license.
    ERROR: Invalid license for emailing: OpenSource license.
    ERROR: Invalid license for marketing: OpenSource license.
    ERROR: Invalid license for productexporter: OpenSource license.
    ERROR: Invalid license for productreturns: OpenSource license.
    ERROR: Invalid license for synchronizer: OpenSource license.
    => Upgarde not applicable
    


    Je veux savoir comment on peux passer à la version 3.5.5.

    Merci



    Édité par bcharfi 12/12/2012 11:37




    RBS Change Version 3.5.2 - eCommerce Core
  • 71982.2 en réponse à 71982.1 écrit par bcharfi

    12/12/2012 14:15


    bcharfi
    Rang : Adepte
    J'ai pu passer à la version 3.5.5 en supprimant les liens symboliques vers les modules qui sont restés en 3.5.2 c.a.d ceux qui présentent des erreurs en lancant la commande updater.migrate download:

    ERROR: Unable to upgrade dashstat-3.5.2
    ERROR: Unable to upgrade ecomextended-3.5.2
    ERROR: Unable to upgrade ecomwebservices-3.5.2
    ERROR: Unable to upgrade emailing-3.5.2
    ERROR: Unable to upgrade marketing-3.5.2
    ERROR: Unable to upgrade productexporter-3.5.2
    ERROR: Unable to upgrade productreturns-3.5.2
    ERROR: Unable to upgrade spreadbutton-3.5.2
    ERROR: Unable to upgrade synchronizer-3.5.2
    

    Édité par bcharfi 12/12/2012 14:19




    RBS Change Version 3.5.2 - eCommerce Core
  • 71982.3 en réponse à 71982.2 écrit par bcharfi

    17/12/2012 11:20


    Gaël Port
    Titre : Développeur RBS Change
    Rang : Expert
    Bonjour,

    Je ne sais pas trop comment cela se fait que certains modules soient restés en version 3.5.2, mais c'est de là que vient le problème initial.

    En effet, lors lors de la sortie d'une nouvelle version, nous sortons systématiquement une nouvelle version de l'ensemble des modules standards (même s'il n'ont pas bougé).

    Donc si à la sortie de la migration 3.5.2 -> 3.5.3 vous avez des modules standard qui sont restés en 3.5.2 c'est que vous avez un problème et c'est à ce moment là déjà qu'il faut regarder ce qui s'est mal passé.
  • 71982.4 en réponse à 71982.2 écrit par bcharfi

    17/12/2012 14:19


    Loïc Couturier
    Rang : Adepte
    Bonjour,
    Vu les erreurs, il semblerait que vous tentiez de mettre à jour un projet contenant des modules soumis à licence sans numéro de licence valide.

    Je vous encourage donc à vérifier cela.
  • 71982.5 en réponse à 71982.2 écrit par bcharfi

    19/12/2012 16:52


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour Béchir,

    Je vous ai contacté par mail afin de vous fournir plus d'informations, mais cela vient en effet d'un problème avec la licence des modules commerciaux.
    Je marque le billet en résolu et reviens vers vous par mail dès que j'ai du nouveau.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1425 membres
Aucun membre connecté