Mises à jour RBS Change : [Résolu] Repository indisponible ?

  • 57227.1

    26/04/2012 09:45


    guiom
    Rang : Expert
    Bonjour,

    Hier j'étais entrain de mettre à niveau des installations en version 3.0.4 vers la 3.5.5. Après pas mal de difficulté à passer en 3.5.3, la migration vers la 3.5.4 à planté car il lui était impossible de télécharger les modules (par exemple : contactcard-3.5.4.zip) alors qu'ils sont indiqués dans repository.xml.

    Ce matin, je veux mettre à niveau un autre site de la 3.5.3 vers la 3.5.4, le module update m'indique bien qu'il y a une mise à jour. Après avoir fait ma sauvegarde, le module update m'indique que je suis à jour (je fait un clear-all avant le compresser le dossier).
    Le repository de ce projet est : http://osrepo.rbschange.fr.

    Merci pour votre aide.

  • 57227.2 en réponse à 57227.1 écrit par guiom

    26/04/2012 09:55


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Bonjour,

    Nous avons modifier les mécaniques de mise à jour et de vérification des licences à l'occasion de la sortie de la 3.5.5. Vous devez maintenant modifier le repository dans le fichier change.properties pour qu'il pointe sur http://update.rbschange.fr.

    En principe cela devrait suffir à corriger votre problème et permettre le passage des mises à jour.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57227.3 en réponse à 57227.2 écrit par Jean-Michel

    26/04/2012 10:12


    guiom
    Rang : Expert
    J'ai réessayé avec le nouveau repository, mais cela ne fonctionne pas et je ne suis pas certain de l'état du projet ensuite. Mise à jour depuis le module update :
    13 steps in upgrade
    ...3.5.3 -> 3.5.4....
    ...
    Download framework-3.5.4
    Download webservices-3.5.4
    [WARN] downloadFile -> Could not download http://update.rbschange.fr/modules/webservices/webservices-3.5.4.zip: bad http status (401)
    => Unable do download : /modules/webservices/webservices-3.5.4.zip in local repository.
    == HELP ==
    Update-dependencies: Update project dependencies
    Usage...
    Execution de l'étape :5 ...
    ...
    

    Au final, le fichier change.xml fait bien référence à la version 3.5.4, le module update me propose la 3.5.5, mais tous les liens (framework et modules) pointe vers la 3.5.3

    J'ai remis le fichier change.xml de la version 3.5.3, mais update me propose toujours la 3.5.5.
    Le site reste fonctionnel, je le garde en état pour le moment s'il vous faut des informations.
    Faudra-t-il restaurer la sauvegarde pour passer les mises à jours ?

    Pour information, le bloc Version des modules affiche :
    Framework : 3.5.4
    Abstractdirectory : Array
    (pour tous les modules) : Array
    

    Merci
    PS: ça serait bien que l'on puisse faire un copier/coller du log de la mise à jour.
  • 57227.4 en réponse à 57227.3 écrit par guiom

    26/04/2012 11:36


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Re,

    Nous avons déverrouillé certaines vérifications pour le contrôle de validité pour la mise à jour qui dans le cas du module webservice étaient un peu trop restrictive pour la version 3.5.4.

    Pour reprendre le processus de mise à jour, voici la marche à suivre :
    - d'abord supprimer le lien symbolique vers le framework version 3.5.4
    - refaire un lien symbolique vers la version 3.5.3 du framework
    - remettre le fichier change.xml de la version 3.5.3
    - relancer le processus de mise à jour

    En principe la mise à jour devrait se dérouler sans problème.

    Édité par Jean-Michel 26/04/2012 11:52


    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57227.5 en réponse à 57227.4 écrit par Jean-Michel

    26/04/2012 11:53


    guiom
    Rang : Expert
    Merci pour l'intervention rapide.
    La mise à jour 3.5.4 est passée correctement.

    Concernant la 3.5.5, j'ai ce message :
    Unable to upgrade abstractdirectory-3.5.2
    Error in license file: ...., OpenSource license.
    Invalid license for abstractdirectory: OpenSource license.

    Du coup la mise à jour n'est pas installation depuis l'interface.
    Est-ce gênant pour passer en 3.5.5 via la ligne de commande ?
    Ce module n'est pas indiqué dans mon change.xml
  • 57227.6 en réponse à 57227.5 écrit par guiom

    26/04/2012 12:03


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Encore un problème de restriction sur le module abstractdirectory.

    Cependant ce module est déprécié. Est-il possible d'avoir votre fichier change.xml afin de voir quel module y fait référence et de pouvoir vous conseiller sur la manière de procéder pour retirer ce module déprécié.

    La relance du processus de mise à jour devrait passer maintenant.

    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
  • 57227.7 en réponse à 57227.6 écrit par Jean-Michel

    26/04/2012 12:07


    guiom
    Rang : Expert
    Merci,
    Voici le fichier change.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <change xmlns="http://www.rbs.fr/schema/change-project/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.rbs.fr/schema/change-project/1.0 http://www.rbschange.fr/static/schema/change-project/1.0.xsd">
      <name>cmscore</name>
      <type>change-project</type>
      <version>3.5.4</version>
      <description>CMS Core</description>
      <dependencies>
        <framework>3.5.4</framework>
        <modules>
          <!-- Core modules -->
          <module>webservices-3.5.4</module>
          <module>mailbox-3.5.4</module>
          <module>contactcard-3.5.4</module>
          <module>filter-3.5.4</module>
          <module>form-3.5.4</module>
          <module>markergas-3.5.4</module>
          <module>skin-3.5.4</module>
          <module>useractionlogger-3.5.4</module>
          <module>uixul-3.5.4</module>
          <module>list-3.5.4</module>
          <module>media-3.5.4</module>
          <module>notification-3.5.4</module>
          <module>generic-3.5.4</module>
          <module>preferences-3.5.4</module>
          <module>mysqlindexer-3.5.4</module>
          <module>solrsearch-3.5.4</module>
          <module>rss-3.5.4</module>
          <module>seo-3.5.4</module>
          <module>dashboard-3.5.4</module>
          <module>task-3.5.4</module>
          <module>theme-3.5.4</module>
          <module>i18n-3.5.4</module>
          <module>users-3.5.4</module>
          <module>website-3.5.4</module>
          <module>workflow-3.5.4</module>
          <module>zone-3.5.4</module>
          <module>twitterconnect-3.5.4</module>
          <module>markergmaps-3.5.4</module>
          <module>event-3.5.4</module>
          <module>photoalbum-3.5.4</module>
          <module>mapping-3.5.4</module>
          <module>videos-3.5.4</module>
          <module>sharethis-3.5.4</module>
          <module>documentcard-3.5.4</module>
          <module>bookmarks-3.5.4</module>
          <module>compatibilityos-3.5.4</module>
          <module>download-3.5.4</module>
          <module>richtext-3.5.4</module>
          <module>updater-3.5.4</module>
        </modules>
      </dependencies>
    </change>

    J'attend vos recommandation avant de faire la mise à jour vers 3.5.5.
  • 57227.8 en réponse à 57227.7 écrit par guiom

    26/04/2012 12:44


    Jean-Michel
    Titre : Community Manager
    Rang : Expert
    Vous pouvez faire la mise à jour sans problème la compatibilité est assurée en 3.5.5.
    Je vous ferais part des choses à modifier un peu plus tard, je ne peux pas me pencher sur la question immédiatement.

    Édité par Jean-Michel 28/08/2012 18:06


    Pour une meilleure réponse, pensez à indiquer la version sur laquelle vous rencontrez des difficultés, ainsi que son type (CMS ou eCommerce core).
    Pour tout problème d'installation indiquez le nom de l'hébergeur et s'il s'agit d'un serveur mutualisé ou dédié.
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1436 membres
Aucun membre connecté