Mises à jour RBS Change : (bis) erreur après migration vers 3.5.1

  • 44729.1

    06/10/2011 15:25


    Mathias
    Rang : Expert
    Bonjour,

    j'ai l'erreur suivante sur le projet que j'ai migré vers la 3.5.1 :
    [ERROR] Dependency users conflict detected: no version intersection between {3.5.0} and {3.5.1}

    est-ce que cette erreur est suffisamment explicite de votre côté pour une solution possible ?
    j'avoue être sur un autre projet en parallèle sur la même vm et depuis 1 semaine je n'avais rien remarqué... donc je ne sais plus vraiment bien quelles actions ont mené à cette erreur...

    Merci pour votre retour

    (ps : ce sujet est un bis suite à l'erreur recontré sur le billet précédemment créé. Le ticket Après déconnexion automatique, il est toujours possible de poster a été créé en conséquence).

    Édité par Mathias 06/10/2011 15:30


    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 44729.2

    06/10/2011 16:36


    Gaël Port
    Titre : Développeur RBS Change
    Rang : Expert
    Bonjour,

    Pouvez-vous préciser si vous êtes passé par la migration via le navigateur ou bien via la ligne de commande ? Et également quand vous obtenez ce message d'erreur ?

    Enfin, pouvez-vous dans les change.xml de chaque module s'il y a une référence à une dépendance en version 3.5.0 ? Ce la peut se faire via la commande unix suivante :
    grep -r '<version>3.5.0</version>' modules/
  • 44729.3 en réponse à 44729.2 écrit par Gaël Port

    06/10/2011 16:40


    Mathias
    Rang : Expert
    Bonjour,

    j'ai réalisé la migration en ligne de commande.
    J'obtiens cette erreur dès que je saisi la moindre ligne de commande.
    même 'change.php' seul me renvoi l'erreur.

    Voici le résultat du grep :

    modules/test/change.xml:        <version>3.5.0</version>
    modules/test/change.xml:                                <version>3.5.0</version>
    modules/septetunelieues/change.xml:     <version>3.5.0</version>
    modules/septetunelieues/change.xml:                             <version>3.5.0</version>
    modules/septetunelieues/.svn/text-base/change.xml.svn-base:     <version>3.5.0</version>
    modules/septetunelieues/.svn/text-base/change.xml.svn-base:                             <version>3.5.0</version>
    modules/workflow/change.xml:        <version>3.5.0</version>
    modules/workflow/change.xml:        <version>3.5.0</version>
    modules/workflow/change.xml:        <version>3.5.0</version>
    


    Les modules test et septetunelieues sont des modules spé.

    Merci !

    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 44729.4 en réponse à 44729.2 écrit par Gaël Port

    06/10/2011 16:52


    Mathias
    Rang : Expert
    Bon ben j'ai modifié les valeurs des dépendences des versions du module workflow vers la 3.5.1 du fichier change.xml.
    Et depuis tout marche bien !

    Merci !!

    Est-ce un bug ? Veux tu que je le remonte dans le bug tracker ?

    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 44729.5

    06/10/2011 17:18


    Gaël Port
    Titre : Développeur RBS Change
    Rang : Expert
    En principe la version actuelle en ligne du module workflow est déjà corrigée sur ce point, donc pas besoin de créer de ticket.

    Est-ce vous auriez téléchargé le package avant l'annonce officielle de la sortie de la 3.5.1 ? (ce problème a été corrigé peu avant de publier l'annonce)
  • 44729.6 en réponse à 44729.5 écrit par Gaël Port

    06/10/2011 17:23


    Mathias
    Rang : Expert
    J'ai le bras long mais pas à ce point ^^

    Par contre il semblerait que ma version 3.5.0 était elle une pré-version fournie par Alexandre Simon lors de la formation.
    La migration vers la 3.5.1 devait justement me permettre d'intégrer les derniers correctifs.

    C'est le seul lien que je vois pour l'expliquer...

    En tout cas c'est résolu :)

    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
  • 44729.7

    07/10/2011 09:11


    Gaël Port
    Titre : Développeur RBS Change
    Rang : Expert
    Je posais la question parce que le paquets étaient déjà téléchargeables plusieurs jours avant l'annonce et que justement celui du module workflow a été corrigé peu avant (lors de la finalisation de la procédure de migration).

    Quoiqu'il en soit, je viens de vérifier le paquet sur le repository et les dépendances sont bonnes pour la version 3.5.1, j'ai donc du mal à comprendre comment vous avez pu vous retrouver avec la mauvaise version...
  • 44729.8 en réponse à 44729.7 écrit par Gaël Port

    07/10/2011 16:40


    Mathias
    Rang : Expert
    Si ça peux aider, après vérif, j'ai téléchargé la nouvelle version le 29/09, suite à la lecture de l'annonce sur la home de rbschange.fr (publiée le 28/09)... en suivant la procédure décrite dans le billet d'annonce et en téléchargeant les paquets via les liens de ce même billet.




    Développe sous linux Ubuntu 12.04 LTS Desktop
    Projet ecommerce core 3.6.7
 
Merci de prendre connaissance et de respecter les règles des forums.
 
1436 membres
Aucun membre connecté